Review Board 2.0.15

x86: implement movntps/movntpd SSE insts

Review Request #3065 - Created Oct. 6, 2015 and updated

Steve Reinhardt
Changeset 11059:fc3d1684cbd1
x86: implement movntps/movntpd SSE insts

These are non-temporal packed SSE stores.  For now, we are not
supporting the cache hints, but are implementing them the same
as the non-hinting movaps/movapd instructions.

Also got rid of the placeholder file that was intended for these insts
(simd128/floating_point/data_transfer/ since it
seemed more logical to put them in with the other moves.


Issue Summary

1 0 0 1
Posted (Oct. 16, 2015, 7:19 p.m.)

Seems fine overall.

Is there a reason to use disp instead of DISPLACEMENT? As far as I can tell,
it should not matter, which makes me wonder why we have three different names: disp, DISPLACMENT and adjustedDisp.
I think all of them translate to the displacement field in the instruction.

  1. As far as I know you are right, they are all the same. I just copied the movaps/movapd code which uses DISPLACEMENT in the first uop and disp in the second. I don't know if there's a reason for that or if it's just arbitrary, but it doesn't make sense to me to make this version different.