Review Board 2.0.15

mem: Make cache terminology easier to understand

Review Request #3254 - Created Dec. 9, 2015 and submitted

Andreas Hansson
Changeset 11281:9538423eb53b
mem: Make cache terminology easier to understand

This patch changes the name of a bunch of packet flags and MSHR member
functions and variables to make the coherency protocol easier to
understand. In addition the patch adds and updates lots of
descriptions, explicitly spelling out assumptions.

The following name changes are made:

* the packet memInhibit flag is renamed to cacheResponding

* the packet sharedAsserted flag is renamed to hasSharers

* the packet NeedsExclusive attribute is renamed to NeedsWritable

* the packet isSupplyExclusive is renamed responderHadWritable

* the MSHR pendingDirty is renamed to pendingModified

The cache states, Modified, Owned, Exclusive, Shared are also called
out in the cache and MSHR code to make it easier to understand.


Issue Summary

27 0 23 4
Description From Last Updated Status
Review request changed
Updated (Dec. 31, 2015, 6:33 a.m.)

Status: Closed (submitted)